Won't open files

Post here any problems you may encounter

Won't open files

Postby slydog3333 » Fri Aug 07, 2015 8:23 pm

Is there a setting I'm missing?

Thanks for bringing this back by the way. The last version I used of this was around 18. Back then opening files was no problem, but now it forces me to save it somewhere even if I click open. I've tried it on several file types and it always make me save it when I click open.
slydog3333
 
Posts: 8
Joined: Fri Aug 07, 2015 8:13 pm

Re: Won't open files

Postby admin » Sun Aug 09, 2015 3:16 am

Hello, open the browser and check if this directory exists %USERPROFILE%\AppData\Local\Chromium\User Data\Default\Cache\Downloads
Advanced Chrome automatically creates that folder when its run and deletes it when you close the app, that folder holds temp downloads when you select "Open", maybe that folder is not writeable? what version of windows you have?
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby slydog3333 » Sun Aug 09, 2015 6:37 pm

I've got Win 7 x64

The folder is created like you said every time it runs, but as you suspected it is marked as read only. Unchecking that doesn't change anything for that session and it's back to read only when it's created again.
slydog3333
 
Posts: 8
Joined: Fri Aug 07, 2015 8:13 pm

Re: Won't open files

Postby admin » Tue Aug 11, 2015 10:41 am

Maybe it is related to the user account permissions you are using, going to try creating a new limited user on windows 7 and check if the problem is present, will post back soon.
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby admin » Tue Aug 11, 2015 11:18 am

Created a limited user account on windows 7 and no problem here, the "read-only" is checked by default and this by itself does not creates the problem.

Your problem must be related to directory permissions, normally they are inherited from parent user folder, create a new user for windows 7 ( Control Panel -> User Accounts -> Manage Another Account -> Create a new Account ) and run the browser using that account, try downloading something to "OPEN" and check if it works, you can delete this account after testing.

If using a new account works properly then you have 2 options, using a new a account or fixing your main account permissions.

To fix your permissions you need to set them properly for %USERPROFILE%\AppData\Local\Chromium\ , right click on chromium at AppData\Local and then go into properties, then go to security tab, then advanced, then press the change permissions button, i am attaching a image here so you can see how it looks like here, basically you can uncheck "include inheritable permissions from object parent" and then setup new permissions:

Allow SYSTEM full control
Allow Administratos full control
Allow YOURUSER full control

If even creating a new user account you still have the same problem then something must be affecting the download directory, can you copy files into it?
Attachments
W7 Deploy.png
W7 Deploy.png (131.32 KiB) Viewed 21098 times
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby slydog3333 » Tue Aug 11, 2015 7:22 pm

Ok I found the solution.

After checking permissions and resetting them and having no success, I tried creating a new user account and that worked.

So I deleted my Chromium folder in AppData which reset everything and it worked again...until I synced my Google account then it went back to the same issues. So I again deleted my appdata folder and tried again, this time I unchecked to sync the settings and this fixed my problem.

Somehow google's sync was overriding advanced chromes setting for opening files. Probably from when I used Chrome briefly after the older version of advanced chrome that I used.
slydog3333
 
Posts: 8
Joined: Fri Aug 07, 2015 8:13 pm

Re: Won't open files

Postby admin » Tue Aug 11, 2015 10:27 pm

Very interesting, I use google sync also and no problems even switching with different chrome and chromium versions, does your directory permissions change the first time it sync? what does it changes exactly?

Try to find out exactly what part of the sync is creating the problem, if you sync everything except "Settings" maybe it stops damaging the local profile.
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby slydog3333 » Wed Aug 12, 2015 7:22 am

My permissions were fine before, full control for everything, I just reapplied to make sure. I'm guessing the setting that was saved in Sync was the download folder? Every time I'd go to open it would pop up with the default downloads folder so maybe it had been hard coded there in my sync settings. If you can switch between chrome and chromium then I'm not sure what caused the issue, I'm just glad it's gone. I just started over with the settings.
slydog3333
 
Posts: 8
Joined: Fri Aug 07, 2015 8:13 pm

Re: Won't open files

Postby admin » Wed Aug 12, 2015 5:53 pm

Yes it is strange, however glad you got it working and hopefully your settings won't start playing funky again, I am still using version 43.0.2350.0 because they are doing terrible work on the newer ones, if you have problems with latest version please report it here.

Have a nice day!
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby manu » Tue Jan 03, 2017 6:41 am

Hello,

I got something new regarding this problem...
I'm having this problem too and was able to fix this when I disabled the checkbox about chromium asking for a location when downloads are supposed to go.
The Open functionality seems to work only in the case where default download location is used.

However, this is exactly the options I want :
- open in the temp directory
- choose a proper location for the file I'm downloading (instead of using the unique location defined in chromium options)

Is this expected behavior?

Thanks for your help!

I used Version 56.0.2910.0 from the 4th december.
manu
 
Posts: 3
Joined: Tue Jan 03, 2017 6:30 am

Re: Won't open files

Postby admin » Mon Jan 09, 2017 10:19 am

You are right, open download asks for download location when "Ask where to save each file before downloading" is enabled, going to fix it right now, thanks for reporting.
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby manu » Mon Jan 09, 2017 10:21 am

Cool!
Thanks for quick fixing!

Looking forward to the update.
manu
 
Posts: 3
Joined: Tue Jan 03, 2017 6:30 am

Re: Won't open files

Postby admin » Mon Jan 09, 2017 1:40 pm

Please try latest version 56.0.2910.0 and check if the issue is fixed.
admin
Site Admin
 
Posts: 144
Joined: Wed Feb 06, 2013 7:47 pm

Re: Won't open files

Postby manu » Tue Jan 10, 2017 2:18 am

It's working, great job!
Thank you
manu
 
Posts: 3
Joined: Tue Jan 03, 2017 6:30 am


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests